TWebBrowser in Factorystudio

Dear experts
In my project, I used TWebBrowser in Display in order to pen Website in Factory studio.
The runtime process work Ok. But when I download a document from this website, there are many download popup were open. Please see picture

I tried download this problem directly from chrome app. It worked Ok.
How can I resolve this probem.

Hi Manh,

Could you please confirm if you are setting the TWebBrowser correctly?
The settings should be like this:

Go in Components > Browse DLLs, and choose the .dll with all the dependecies in the same folder. And click in the screen to add the TWebBrowser

Than you go in Run > Build > References to see if it was imported correctly:

Than you double click in the object and configure like this, the “Tag.urlName” contains the string url.

In the CodeBehind should be like this:

Best Regards,
Tatsoft Team.

Dear Eduardo
Thank for your comment.
I didn’t see TCellBrowserWPF.dll file in the path.
Do I have download it from internet?

Hi Manh,

You can download it in the following path:

Then you put all this folder inside of : “C:\Program Files (x86)\Tatsoft\FactoryStudio\fs-9.2\WpfControls”

And follow the steps we have said in this topic.

Is this what you were looking for?

Tatsoft Team.